Free advertising for your Joomla business

Question PHP Mailer Security Issue

  • Laurie
  • Laurie's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
More
2 years 11 months ago #190 by Laurie
PHP Mailer Security Issue was created by Laurie
Hi there!

I received the following Joomla Security Email. Not clear on whether I should take any action. I have several contact forms created using Chronoforms:

Joomla! Security News


[20161205] - PHPMailer Security Advisory

Posted: 27 Dec 2016 12:00 AM PST

Project: Joomla!
Severity: High
Versions: 1.6.0 through 3.6.5
Exploit type: Remote Code Execution in third-party PHPMailer library
CVE Number: CVE-2016-10033

Description

All versions of the third-party PHPMailer library distributed with Joomla! versions up to 3.6.5 are vulnerable to a remote code execution vulnerability. This is patched in PHPMailer 5.2.18 which will be included with Joomla! 3.7. After analysis, the JSST has determined that through correct use of the JMail class, there are additional validations in place which make executing this vulnerability impractical within the Joomla environment. As well, the vulnerability requires being able to pass user input to a message’s “from” address; all places in the core Joomla API which send mail use the sender address set in the global configuration and does not allow for user input to be set elsewhere. However, extensions which bundle a separate version of PHPMailer or do not use the Joomla API to send email may be vulnerable to this issue.

Generally, the Joomla project does not issue advisories regarding third party libraries, however given the severity of this issue we felt it important to advise our users that we are aware of this issue and we have determined that the additional validations in our API prevent triggering this vulnerability.
Affected Installs

Joomla! CMS versions 1.6.0 through 3.6.5
Solution

No action required for Joomla users, the updated library will be included in the next scheduled release and additional mechanisms exist in Joomla core to prevent triggering the vulnerability. Users of the PHPMailer library separate from Joomla are advised to upgrade to 5.2.18 or newer ASAP.
Additional Resources

legalhackers.com/advisories/PHPMailer-Ex...2016-10033-Vuln.html
github.com/PHPMailer/PHPMailer/blob/master/SECURITY.md

Contact

The JSST at the Joomla! Security Centre.
Reported By: Dawid Golunski


Thanks,
Laurie.

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #191 by sozzled
Replied by sozzled on topic PHP Mailer Security Issue
I read a discussion on this subject at the Joomla forum and I concluded there was little to be too concerned about. See forum.joomla.org/viewtopic.php?f=714&t=944073

Read my blog and
File Attachment:

Please Log in or Create an account to join the conversation.

Time to create page: 0.263 seconds